package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ims)^(?:sl2|sf2)(?:dev|pra|prb|pre)`)
var str = `A wonderful little production. <br /><br />The
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}