import re
regex = re.compile(r"""
^(?:sl2|sf2)(?:dev|pra|prb|pre)
""", flags=re.IGNORECASE | re.VERBOSE | re.MULTILINE | re.DOTALL)
test_str = ("A wonderful little production. <br /><br />The\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")