const regex = /^(?:sl2|sf2)(?:dev|pra|prb|pre)/ims;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:sl2|sf2)(?:dev|pra|prb|pre)', 'ims')
const str = `A wonderful little production. <br /><br />The
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}