$re = '/^(?:sl2|sf2)(?:dev|pra|prb|pre)/ixms';
$str = 'A wonderful little production. <br /><br />The
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);