using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(.*?)""";
string input = @"01 – Root Books <a href=""http://mylinkforgoogle.com.pdf""
shokly <a href=""http://mylinkforgoogle.com.pdf""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}