package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`href="(.*?)"`)
var str = `01 – Root Books <a href="http://mylinkforgoogle.com.pdf"
shokly <a href="http://mylinkforgoogle.com.pdf"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}