$re = '/href="(.*?)"/';
$str = '01 – Root Books <a href="http://mylinkforgoogle.com.pdf"
shokly <a href="http://mylinkforgoogle.com.pdf"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);