re = /href="(.*?)"/
str = '01 – Root Books <a href="http://mylinkforgoogle.com.pdf"
shokly <a href="http://mylinkforgoogle.com.pdf"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end