import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span id=\"ctl00_MainContent_ListView2_ctrl2_ctl01_[^\"]+\" class=\"vehicledetailTable\" style=\"display:inline-block;width:475px;\">OWNED</span><br />";
final String string = "<span id=\"ctl00_MainContent_ListView2_ctrl2_ctl01_Label17\" class=\"vehicledetailTable\" style=\"display:inline-block;width:475px;\">OWNED</span><br />\n\n"
+ "<span id=\"ctl00_MainContent_ListView2_ctrl2_ctl01_Label18\" class=\"vehicledetailTable\" style=\"display:inline-block;width:475px;\">OWNED</span><br />\n\n"
+ "<span id=\"ctl00_MainContent_ListView2_ctrl2_ctl01_Label19\" class=\"vehicledetailTable\" style=\"display:inline-block;width:475px;\">OWNED</span><br />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}