$re = '~<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_[^"]+" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />~';
$str = '<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_Label17" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />
<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_Label18" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />
<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_Label19" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);