import Foundation
let pattern = #"<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_[^"]+" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_Label17" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />
<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_Label18" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />
<span id="ctl00_MainContent_ListView2_ctrl2_ctl01_Label19" class="vehicledetailTable" style="display:inline-block;width:475px;">OWNED</span><br />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)