const regex = /[^\p{L} ]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{L} ]+', 'gu')
const str = `one two three !@#\$%^&*()_+|`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);