$re = '/[^\p{L} ]+/u';
$str = 'one two three !@#$%^&*()_+|';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;