use strict;
my $str = 'one two three !@#$%^&*()_+|';
my $regex = qr/[^\p{L} ]+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";