#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)[0-9]+ # first number" & @CRLF & _
"\s* # any whitespace" & @CRLF & _
"[\+\*-\/] # operand" & @CRLF & _
"\s* # any whitespace" & @CRLF & _
"[0-9]+ # second number"
Local $sString = "5 , 8" & @CRLF & _
"5 . 8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")