import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+ # first number\n"
+ "\\s* # any whitespace\n"
+ "[\\+\\*-\\/] # operand\n"
+ "\\s* # any whitespace\n"
+ "[0-9]+ # second number";
final String string = "5 , 8\n"
+ "5 . 8";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}