using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+ # first number
\s* # any whitespace
[\+\*-\/] # operand
\s* # any whitespace
[0-9]+ # second number";
string input = @"5 , 8
5 . 8";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}