$re = '/[0-9]+ # first number
\s* # any whitespace
[\+\*-\/] # operand
\s* # any whitespace
[0-9]+ # second number/x';
$str = '5 , 8
5 . 8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);