import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\t+(.*?)\\t+(.*?)\\t+(.*?)$";
final String string = "Apple 10 June Mexico\n"
+ "Grape 27 February Canada\n"
+ "Banana August Peru";
final String subst = "(\\1)\\t(\\2)\\t(\\3)\\t(\\4)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}