// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?)\t+(.*?)\t+(.*?)\t+(.*?)$").unwrap();
let string = "Apple 10 June Mexico
Grape 27 February Canada
Banana August Peru";
let substitution = "(\\1)\\t(\\2)\\t(\\3)\\t(\\4)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}