import Foundation
let pattern = #"^(.*?)\t+(.*?)\t+(.*?)\t+(.*?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Apple 10 June Mexico
Grape 27 February Canada
Banana August Peru
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1)\t(\2)\t(\3)\t(\4)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)