#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?!00)[0-1][0-9]|2[1-4]):[0-5][0-9]"
Local $sString = "00:00" & @CRLF & _
"01:00" & @CRLF & _
"02:00" & @CRLF & _
"03:00" & @CRLF & _
"04:00" & @CRLF & _
"05:00" & @CRLF & _
"06:00" & @CRLF & _
"07:00" & @CRLF & _
"08:00" & @CRLF & _
"09:00" & @CRLF & _
"10:00" & @CRLF & _
"11:00" & @CRLF & _
"12:00" & @CRLF & _
"13:00" & @CRLF & _
"14:00" & @CRLF & _
"15:00" & @CRLF & _
"16:00" & @CRLF & _
"17:00" & @CRLF & _
"18:00" & @CRLF & _
"19:00" & @CRLF & _
"21:00" & @CRLF & _
"22:00" & @CRLF & _
"23:00" & @CRLF & _
"24:00" & @CRLF & _
"24:00" & @CRLF & _
"24:59" & @CRLF & _
"24:60" & @CRLF & _
"24:21" & @CRLF & _
"22:42" & @CRLF & _
"25:00" & @CRLF & _
"26:00" & @CRLF & _
"27:00" & @CRLF & _
"28:00" & @CRLF & _
"29:00" & @CRLF & _
"30:00" & @CRLF & _
"31:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")