re = /((?!00)[0-1][0-9]|2[1-4]):[0-5][0-9]/
str = '00:00
01:00
02:00
03:00
04:00
05:00
06:00
07:00
08:00
09:00
10:00
11:00
12:00
13:00
14:00
15:00
16:00
17:00
18:00
19:00
21:00
22:00
23:00
24:00
24:00
24:59
24:60
24:21
22:42
25:00
26:00
27:00
28:00
29:00
30:00
31:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end