import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?!00)[0-1][0-9]|2[1-4]):[0-5][0-9]";
final String string = "00:00\n"
+ "01:00\n"
+ "02:00\n"
+ "03:00\n"
+ "04:00\n"
+ "05:00\n"
+ "06:00\n"
+ "07:00\n"
+ "08:00\n"
+ "09:00\n"
+ "10:00\n"
+ "11:00\n"
+ "12:00\n"
+ "13:00\n"
+ "14:00\n"
+ "15:00\n"
+ "16:00\n"
+ "17:00\n"
+ "18:00\n"
+ "19:00\n"
+ "21:00\n"
+ "22:00\n"
+ "23:00\n"
+ "24:00\n"
+ "24:00\n"
+ "24:59\n"
+ "24:60\n"
+ "24:21\n"
+ "22:42\n"
+ "25:00\n"
+ "26:00\n"
+ "27:00\n"
+ "28:00\n"
+ "29:00\n"
+ "30:00\n"
+ "31:00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}