# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?!00)[0-1][0-9]|2[1-4]):[0-5][0-9]"
test_str = ("00:00\n"
"01:00\n"
"02:00\n"
"03:00\n"
"04:00\n"
"05:00\n"
"06:00\n"
"07:00\n"
"08:00\n"
"09:00\n"
"10:00\n"
"11:00\n"
"12:00\n"
"13:00\n"
"14:00\n"
"15:00\n"
"16:00\n"
"17:00\n"
"18:00\n"
"19:00\n"
"21:00\n"
"22:00\n"
"23:00\n"
"24:00\n"
"24:00\n"
"24:59\n"
"24:60\n"
"24:21\n"
"22:42\n"
"25:00\n"
"26:00\n"
"27:00\n"
"28:00\n"
"29:00\n"
"30:00\n"
"31:00")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.