#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)entest"
Local $sString = "members/kaleem/" & @CRLF & _
"members/kaleem/activity/just-me/" & @CRLF & _
"members/kaleem/activity/" & @CRLF & _
"members/kaleem/activity/favorites/" & @CRLF & _
"members/kaleem/activity/groups/" & @CRLF & _
"members/kaleem/friends/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")