using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"entest";
string input = @"members/kaleem/
members/kaleem/activity/just-me/
members/kaleem/activity/
members/kaleem/activity/favorites/
members/kaleem/activity/groups/
members/kaleem/friends/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}