re = /entest/m
str = 'members/kaleem/
members/kaleem/activity/just-me/
members/kaleem/activity/
members/kaleem/activity/favorites/
members/kaleem/activity/groups/
members/kaleem/friends/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end