using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"function\([\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'\)";
string input = @"function( '12', 'World34' , '456' ,'Hello')";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}