re = /function\([\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'\)/
str = 'function( \'12\', \'World34\' , \'456\' ,\'Hello\')'
# Print the match result
str.match(re) do |match|
puts match.to_s
end