const regex = /function\([\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('function\\([\\s]*?\'([\\S]*?)\'[\\s]*?,[\\s]*?\'([\\S]*?)\'[\\s]*?,[\\s]*?\'([\\S]*?)\'[\\s]*?,[\\s]*?\'([\\S]*?)\'\\)', '')
const str = `function( '12', 'World34' , '456' ,'Hello')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}