package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`function\([\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'[\s]*?,[\s]*?'([\S]*?)'\)`)
var str = `function( '12', 'World34' , '456' ,'Hello')`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}