using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0031]{4}[0-9]{8}[^a-z]|^[\+][0-9]{10}[^a-z]|^[06]{2}[\-][0-9]{7}[^a-z]|^[0-9]{3}[\-][0-9]{6}[^a-z]|^[0]{1}[0-9]{8}[^a-z]";
string input = @"077-3820843";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}