import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0031]{4}[0-9]{8}[^a-z]|^[\\+][0-9]{10}[^a-z]|^[06]{2}[\\-][0-9]{7}[^a-z]|^[0-9]{3}[\\-][0-9]{6}[^a-z]|^[0]{1}[0-9]{8}[^a-z]";
final String string = "077-3820843";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}