use strict;
my $str = '077-3820843';
my $regex = qr/^[0031]{4}[0-9]{8}[^a-z]|^[\+][0-9]{10}[^a-z]|^[06]{2}[\-][0-9]{7}[^a-z]|^[0-9]{3}[\-][0-9]{6}[^a-z]|^[0]{1}[0-9]{8}[^a-z]/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}