const regex = /^[0031]{4}[0-9]{8}[^a-z]|^[\+][0-9]{10}[^a-z]|^[06]{2}[\-][0-9]{7}[^a-z]|^[0-9]{3}[\-][0-9]{6}[^a-z]|^[0]{1}[0-9]{8}[^a-z]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0031]{4}[0-9]{8}[^a-z]|^[\\+][0-9]{10}[^a-z]|^[06]{2}[\\-][0-9]{7}[^a-z]|^[0-9]{3}[\\-][0-9]{6}[^a-z]|^[0]{1}[0-9]{8}[^a-z]', 'i')
const str = `077-3820843`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}