#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^XYZ]|X(?!YZ)|Y(?!Z)|(?<!X)Y|(?<!XY)Z"
Local $sString = "abXYxyzXYZ"
Local $sSubst = "+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)