use strict;
my $str = 'abXYxyzXYZ';
my $regex = qr/[^XYZ]|X(?!YZ)|Y(?!Z)|(?<!X)Y|(?<!XY)Z/p;
my $subst = '+';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";