re = /[^XYZ]|X(?!YZ)|Y(?!Z)|(?<!X)Y|(?<!XY)Z/
str = 'abXYxyzXYZ'
subst = '+'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result