$re = '/[^XYZ]|X(?!YZ)|Y(?!Z)|(?<!X)Y|(?<!XY)Z/';
$str = 'abXYxyzXYZ';
$subst = "+";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;