using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([^\[]+)\[([^\]]+)\])";
string input = @"/foo[123abc]/bar[52.1,23.42]/baz[2u-c0ffee]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}