re = /(?:([^\[]+)\[([^\]]+)\])/
str = '/foo[123abc]/bar[52.1,23.42]/baz[2u-c0ffee]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end