$re = '/(?:([^\[]+)\[([^\]]+)\])/';
$str = '/foo[123abc]/bar[52.1,23.42]/baz[2u-c0ffee]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);