package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:([^\[]+)\[([^\]]+)\])`)
var str = `/foo[123abc]/bar[52.1,23.42]/baz[2u-c0ffee]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}