#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?(DEFINE)" & @CRLF & _
"(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])" & @CRLF & _
")" & @CRLF & _
"(" & @CRLF & _
" 10\." & @CRLF & _
" ((?&bit)\.){2}((?&bit))" & @CRLF & _
")|" & @CRLF & _
"(" & @CRLF & _
" 172\." & @CRLF & _
" (" & @CRLF & _
" (1[6-9])|" & @CRLF & _
" (2[0-9])|" & @CRLF & _
" (3[0-6])" & @CRLF & _
" )" & @CRLF & _
" \." & @CRLF & _
" ((?&bit)\.?+){2}" & @CRLF & _
")|" & @CRLF & _
"(" & @CRLF & _
" 192\.168\." & @CRLF & _
" ((?&bit)\.?+){2}" & @CRLF & _
")"
Local $sString = "172.31.253.126"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")