const regex = /(?(DEFINE)
(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])
)
(
10\.
((?&bit)\.){2}((?&bit))
)|
(
172\.
(
(1[6-9])|
(2[0-9])|
(3[0-6])
)
\.
((?&bit)\.?+){2}
)|
(
192\.168\.
((?&bit)\.?+){2}
)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])
)
(
10\\.
((?&bit)\\.){2}((?&bit))
)|
(
172\\.
(
(1[6-9])|
(2[0-9])|
(3[0-6])
)
\\.
((?&bit)\\.?+){2}
)|
(
192\\.168\\.
((?&bit)\\.?+){2}
)', '')
const str = `172.31.253.126`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}