import Foundation
let pattern = #"""
(?(DEFINE)
(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])
)
(
10\.
((?&bit)\.){2}((?&bit))
)|
(
172\.
(
(1[6-9])|
(2[0-9])|
(3[0-6])
)
\.
((?&bit)\.?+){2}
)|
(
192\.168\.
((?&bit)\.?+){2}
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"172.31.253.126"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}