use strict;
my $str = '172.31.253.126';
my $regex = qr/(?(DEFINE)
(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])
)
(
10\.
((?&bit)\.){2}((?&bit))
)|
(
172\.
(
(1[6-9])|
(2[0-9])|
(3[0-6])
)
\.
((?&bit)\.?+){2}
)|
(
192\.168\.
((?&bit)\.?+){2}
)/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}