import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*)(?!pub(?:\\s|\\(.*?\\)\\s))(?!_)([_\\p{L}][\\p{L}0-9_]*\\s*:)";
final String string = "struct Foo {\n"
+ " #[some(attr)]\n"
+ " ptr: Bar,\n"
+ " /// pub\n"
+ " /// lorem\n"
+ " inner: Baz,\n"
+ " _marker: Phantom,\n"
+ " ///\n"
+ " pub corge: Corge\n"
+ " pub(crate) qux: Qux,\n"
+ " pub(self) quxx: Quxx,\n"
+ " hoge: Hoge,\n"
+ " pub fuga: Fuga,\n"
+ " publish: Pub,\n"
+ " pub_lish: Pub,\n"
+ "}";
final String subst = "$1pub $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}