const regex = /^(\s*)(?!pub(?:\s|\(.*?\)\s))(?!_)([_\p{L}][\p{L}0-9_]*\s*:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*)(?!pub(?:\\s|\\(.*?\\)\\s))(?!_)([_\\p{L}][\\p{L}0-9_]*\\s*:)', 'gm')
const str = `struct Foo {
#[some(attr)]
ptr: Bar,
/// pub
/// lorem
inner: Baz,
_marker: Phantom,
///
pub corge: Corge
pub(crate) qux: Qux,
pub(self) quxx: Quxx,
hoge: Hoge,
pub fuga: Fuga,
publish: Pub,
pub_lish: Pub,
}`;
const subst = `$1pub $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);